How can we help you?

What are the minimum system requirements to use Small World?

To ensure the best security and functionality, you should use the latest update of your browser.

The minimum versions of the browsers to ensure the best experience with Small World are the following:

  • Internet Explorer 11 (Edge recommended)
  • FireFox:Firefox 60
  • Safari: Safari 11
  • Google Chrome: Chrome 62
  • Others: Opera 55

iOS devices.

  • iPad: iPad 2nd Generation (iOS9)
  • iPhone: iPhone 4S (iOS9)

Android devices: compatible devices with Android 4.2.2

Was this article helpfull?
Yes
No

Can´t find your answer? Contact us
We gebruiken cookies om u de best mogelijke browse-ervaring te bieden en om te begrijpen hoe u onze site gebruikt. Door op "Accepteren" te klikken, accepteert u deze cookies. U kunt uw voorkeuren op elk moment wijzigen - en er meer over te weten komen - door te volgen deze link.